NMU, fix FTBFS with boost1.67 releasing package anytun version 0.3.7-1.1
authorDimitri John Ledkov <xnox@ubuntu.com>
Sun, 18 Nov 2018 01:04:51 +0000 (01:04 +0000)
committerDimitri John Ledkov <xnox@ubuntu.com>
Sun, 18 Nov 2018 01:04:51 +0000 (01:04 +0000)
debian/changelog
debian/patches/02-boost1.67.patch [new file with mode: 0644]
debian/patches/series

index 98416af..c43b1e5 100644 (file)
@@ -1,3 +1,10 @@
+anytun (0.3.7-1.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix FTBFS with boost 1.67.
+
+ -- Dimitri John Ledkov <xnox@ubuntu.com>  Sat, 28 Jul 2018 01:29:20 +0100
+
 anytun (0.3.7-1) unstable; urgency=medium
 
   * [6294e1d] New upstream version 0.3.7
diff --git a/debian/patches/02-boost1.67.patch b/debian/patches/02-boost1.67.patch
new file mode 100644 (file)
index 0000000..359b2d9
--- /dev/null
@@ -0,0 +1,22 @@
+--- anytun-0.3.7.orig/src/anytunError.cpp
++++ anytun-0.3.7/src/anytunError.cpp
+@@ -64,6 +64,6 @@ std::ostream& operator<<(std::ostream& s
+ std::ostream& operator<<(std::ostream& stream, AnytunErrno const& value)
+ {
+-  boost::system::system_error err(boost::system::error_code(value.err_, boost::system::get_system_category()));
++  boost::system::system_error err(boost::system::error_code(value.err_, boost::system::system_category()));
+   return stream << err.what();
+ }
+--- anytun-0.3.7.orig/src/resolver.cpp
++++ anytun-0.3.7/src/resolver.cpp
+@@ -81,7 +81,7 @@ ResolveHandler<Proto>::ResolveHandler(co
+ template<class Proto>
+ void ResolveHandler<Proto>::operator()(const boost::system::error_code& e, boost::asio::ip::basic_resolver_iterator<Proto> endpointIt)
+ {
+-  if(boost::system::posix_error::success == e) {
++  if(boost::system::errc::success == e) {
+     try {
+       onResolve_(endpointIt);
+     } catch(const std::runtime_error& e) {
+
index ddf5535..e3093ec 100644 (file)
@@ -1 +1,2 @@
 01-fix-typos
+02-boost1.67.patch