Drop asciidoc and related packages from build-depends and ship manpages statically...
[anytun.git] / debian / rules
index 728d44d..f5b1bfe 100755 (executable)
@@ -12,7 +12,7 @@
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       cd src && ./configure --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/anytun/examples && cd ..
+       cd src && ./configure --no-manpage --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/anytun/examples && cd ..
        touch configure-stamp
 
 build: build-stamp
@@ -29,11 +29,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       cd src && $(MAKE) distclean && cd ..
-
-       # drop leftover file:
-       rm -f src/tun.c
-
        # Add here commands to clean up after the build process.
        $(MAKE) --directory=$(CURDIR)/src distclean
        dh_clean
@@ -59,6 +54,7 @@ binary-arch: install
        dh_testroot
        dh_installchangelogs ChangeLog
        dh_installdocs
+       dh_installman debian/anytun.8 debian/anytun-config.8 debian/anytun-controld.8 debian/anytun-showtables.8
        dh_installexamples
        dh_installinit
        dh_link