Initial Debian packaging; add src/include.mk
authorMichael Prokop <mika@grml.org>
Fri, 29 May 2009 20:23:16 +0000 (22:23 +0200)
committerMichael Prokop <mika@grml.org>
Fri, 29 May 2009 20:29:39 +0000 (22:29 +0200)
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/rules [new file with mode: 0755]
src/include.mk [new file with mode: 0644]

diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..19f618a
--- /dev/null
@@ -0,0 +1,6 @@
+uanytun (0.3-1) unstable; urgency=low
+
+  * Initial release (Closes: #531082)
+
+ -- Michael Prokop <mika@debian.org>  Fri, 29 May 2009 22:19:50 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7ed6ff8
--- /dev/null
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..d784fe9
--- /dev/null
@@ -0,0 +1,27 @@
+Source: uanytun
+Section: net
+Priority: extra
+Maintainer: Michael Prokop <mika@debian.org>
+Build-Depends: debhelper (>= 5), libgcrypt11-dev, asciidoc
+Standards-Version: 3.8.1
+Homepage: http://www.anytun.org/
+VCS-svn: https://svn.chaos-at-home.org/uanytun/
+VCS-Browser: https://svn.chaos-at-home.org/uanytun/
+
+Package: uanytun
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: tiny implementation of the secure anycast tunneling protocol
+ uAnytun is a tiny implementation of SATP (Secure Anycast Tunneling                                                                                                               
+ Protocol). Unlike Anytun which is a full featured implementation                                                                                                                 
+ uAnytun has no support for multiple connections or synchronisation.
+ It is a small single threaded implementation intended to act as a
+ client on small platforms. SATP defines a protocol used for
+ communication between any combination of unicast and anycast tunnel
+ endpoints. It has less protocol overhead than IPSec in Tunnel mode
+ and allows tunneling of every ETHER TYPE protocol (e.g. ethernet,
+ ip, arp ...). SATP directly includes cryptography and message
+ authentication based on the methodes used by SRTP (Secure Real-time
+ Transport Protocol). It is intended to deliver a generic,
+ scaleable and secure solution for tunneling and relaying of packets
+ of any protocol.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..2e01164
--- /dev/null
@@ -0,0 +1,30 @@
+This package was debianized by Michael Prokop <mika@debian.org> on
+Fri, 29 May 2009 11:23:42 +0200.
+
+It was downloaded from <http://www.anytun.org/>
+
+Upstream Author: Christian Pointner <equinox@anytun.org>
+
+Copyright: 2007-2008 Christian Pointner
+
+License:
+
+    This program is free software; you can redistribute it and/or modify
+    it under the terms of the GNU General Public License as published by
+    the Free Software Foundation; either version 3 of the License, or
+    (at your option) any later version.
+
+    This program is distributed in the hope that it will be useful,
+    but WITHOUT ANY WARRANTY; without even the implied warranty of
+    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+    GNU General Public License for more details.
+
+    You should have received a copy of the GNU General Public License
+    along with this package; if not, write to the Free Software
+    Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-3'.
+
+The Debian packaging is © 2009, Michael Prokop <mika@debian.org> and
+is licensed under the GPL, see above.
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..512ff1c
--- /dev/null
@@ -0,0 +1,75 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       cd src && ./configure && cd ..
+       touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+       dh_testdir
+
+       cd src && $(MAKE) && cd ..
+       cd doc && $(MAKE) && cd ..
+
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       # workarounds:
+       touch src/include.mk
+       rm -f src/tun.c
+
+       cd src && $(MAKE) clean && cd ..
+       cd doc && $(MAKE) clean && cd ..
+
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_installdirs usr/sbin usr/share/uanytun/examples/config
+
+       # Add here commands to install the package into debian/uanytun.
+       install -m 755 src/uanytun debian/uanytun/usr/sbin/
+       cp -a etc/uanytun/*        debian/uanytun/usr/share/uanytun/examples/config/
+
+# Build architecture-independent files here.
+binary-indep: install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs ChangeLog
+       dh_installdocs
+       dh_installexamples
+       dh_installinit etc/init.d/uanytun
+       dh_installman doc/uanytun.8
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/src/include.mk b/src/include.mk
new file mode 100644 (file)
index 0000000..83a992b
--- /dev/null
@@ -0,0 +1,14 @@
+# this file was created automatically
+# do not edit this file directly 
+# use ./configure instead
+
+TARGET := Linux
+CC := gcc
+CFLAGS := -g -O2
+LDFLAGS := -g -Wall -O2 -lgcrypt
+
+SBINDIR := /usr/local/sbin
+MANDIR := /usr/local/share/man
+ETCDIR := /usr/local/etc
+USERNAME := uanytun
+USERHOME := /var/run/uanytun