Enable systemd integration
[anytun.git] / debian / rules
index f5b1bfe..ba19bca 100755 (executable)
@@ -1,13 +1,17 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
 
 configure: configure-stamp
 configure-stamp:
@@ -15,7 +19,10 @@ configure-stamp:
        cd src && ./configure --no-manpage --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/anytun/examples && cd ..
        touch configure-stamp
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: configure-stamp
        dh_testdir
@@ -54,8 +61,9 @@ binary-arch: install
        dh_testroot
        dh_installchangelogs ChangeLog
        dh_installdocs
-       dh_installman debian/anytun.8 debian/anytun-config.8 debian/anytun-controld.8 debian/anytun-showtables.8
+       dh_installman doc/anytun.8 doc/anytun-config.8 doc/anytun-controld.8 doc/anytun-showtables.8
        dh_installexamples
+       dh_systemd_enable anytun.service
        dh_installinit
        dh_link
        dh_strip