Update debian/rules file
authorDarshaka Pathirana <dpat@syn-net.org>
Mon, 11 Jun 2018 00:20:22 +0000 (02:20 +0200)
committerDarshaka Pathirana <dpat@syn-net.org>
Tue, 12 Jun 2018 22:56:00 +0000 (00:56 +0200)
In the course of updating the package to the latest Debian
Standards-Version I wanted to bring the debian/rules file up-to-date.
I generated a new template with dh_make(1) with the --addmissing option
and merged the header of template to the existing rules file. (Changing
the rest is work-in-progress and will follow at some later time).

The new template introduces the DPKG_EXPORT_BUILDFLAGS variable which
exports "all buildflags into the environment (where they can be picked
up by your build system)", see: dpkg-buildflags(1).

Exporting the buildflags caused some problems, because of a bug in the
"./configure"-script. This has been fixed with the patch, which has been
introduced in commit 93406119.

debian/rules

index 08bfb72..dd296e9 100755 (executable)
@@ -1,13 +1,20 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+# DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
 configure: configure-stamp
 configure-stamp: