Imported Upstream version 0.3.3
[debian/uanytun.git] / src / configure
index ac2dc03..ee80582 100755 (executable)
@@ -16,7 +16,7 @@
 #  tunneling and relaying of packets of any protocol.
 #  
 #
-#  Copyright (C) 2007-2008 Christian Pointner <equinox@anytun.org>
+#  Copyright (C) 2007-2010 Christian Pointner <equinox@anytun.org>
 #
 #  This file is part of uAnytun.
 #
@@ -43,7 +43,6 @@ LDFLAGS='-g -Wall -O2'
 
 CRYPTO_LIB='gcrypt'
 PASSPHRASE=1
-V4_MAPPED=1
 
 PREFIX='/usr/local'
 SBINDIR=''
@@ -67,9 +66,6 @@ print_usage() {
   echo "          --no-crypto               disable crypto at all (only NULL cipher)"
   echo "          --disable-passphrase      disable master key and salt passphrase"
   echo "          --enable-passphrase       enable master key and salt passphrase"
-  echo "          --disable-v4-mapped       disable V4-Mapped addresses (this means to disable"
-  echo "                                    simultanious use of IPv4 and IPv6)"
-  echo "          --enable-v4-mapped        enable V4-Mapped addresses"
 }
 
 for arg
@@ -111,12 +107,6 @@ do
   --enable-passphrase)
     PASSPHRASE=1
   ;;
-  --disable-v4-mapped)
-    V4_MAPPED=0 
-  ;; 
-  --enable-v4-mapped)
-    V4_MAPPED=2
-  ;; 
   --ebuild-compat)
     EBUILD_COMPAT=1
   ;;
@@ -139,7 +129,7 @@ if [ -n "$ERRORS" ] && [ $EBUILD_COMPAT -ne 1 ]; then
   exit 1
 fi
 
-
+rm -f version.h
 rm -f include.mk
 case $TARGET in 
   Linux)
@@ -153,12 +143,9 @@ case $TARGET in
     echo "loading BSD specific TUN Device"
     CFLAGS=$CFLAGS' -I/usr/local/include'
     LDFLAGS=$LDFLAGS' -L/usr/local/lib'
-    if [ $V4_MAPPED -ne 2 ]; then
-      V4_MAPPED=0
-    fi
   ;;
   *)
-    echo "Plattform not supported"
+    echo "platform not supported"
     exit 1;
   ;;
 esac
@@ -186,11 +173,6 @@ if [ $PASSPHRASE -eq 0 ]; then
   echo "disabling master key and salt passphrase"
 fi
 
-if [ $V4_MAPPED -eq 0 ]; then
-  CFLAGS=$CFLAGS' -DNO_V4MAPPED'
-  echo "WARNING: disabling V4 mapped addresses, this prevents uanytun from using IPv6 and IPv4 Sockets at the same time"
-fi
-
 if [ -z "$SBINDIR" ]; then
   SBINDIR=$PREFIX/sbin
 fi
@@ -238,4 +220,33 @@ else
   echo "not installing example files"
 fi
 
+VERSION=`cat ../version`
+if which svn >/dev/null; then
+  SVN_REV=`svn info | grep "^Revision: " | awk '{print($2)}'`
+  if [ -n "$SVN_REV" ]; then
+    VERSION="$VERSION (svn$SVN_REV)"
+  fi
+fi
+HOSTNAME=`hostname`
+DATE=`date +"%d.%m.%Y %H:%M:%S %Z"`
+
+cat >> version.h <<EOF
+/* 
+ * uanytun version info
+ *
+ * this file was created automatically
+ * do not edit this file directly
+ * use ./configure instead
+ */
+
+#ifndef UANYTUN_version_h_INCLUDED
+#define UANYTUN_version_h_INCLUDED
+
+#define VERSION_STRING_0 "uanytun version $VERSION"
+#define VERSION_STRING_1 "built on $HOSTNAME, $DATE"
+
+#endif
+
+EOF
+
 exit 0