Imported Upstream version 0.3.2
[debian/uanytun.git] / doc / Makefile
index f49deda..97db23e 100644 (file)
@@ -20,8 +20,9 @@
 ##  This file is part of uAnytun.
 ##
 ##  uAnytun is free software: you can redistribute it and/or modify
-##  it under the terms of the GNU General Public License version 3 as
-##  published by the Free Software Foundation.
+##  it under the terms of the GNU General Public License as published by
+##  the Free Software Foundation, either version 3 of the License, or
+##  any later version.
 ##
 ##  uAnytun is distributed in the hope that it will be useful,
 ##  but WITHOUT ANY WARRANTY; without even the implied warranty of
 ##  along with uAnytun. If not, see <http://www.gnu.org/licenses/>.
 ##
 
+VERSION=$(shell cat ../version)
+
+.PHONY: clean 
+
 all: manpage
 
 uanytun.8: uanytun.8.txt
-       a2x -f manpage uanytun.8.txt
+       a2x -f manpage $<
+       @ sed -i -e 's/\[FIXME: source\]/uanytun ${VERSION}/' $@
+       @ sed -i -e 's/\[FIXME: manual\]/uanytun user manual/' $@
+       @ sed -i -e 's/^uanytun$$/\\fBuanytun\\fR/' $@
+       @ sed -i -e 's/^  \[ \([^ ]*\)/  [ \\fB\1\\fR/' $@
 
 manpage: uanytun.8