Fix typo in manpage
[debian/uanytun.git] / debian / rules
index 6212bf6..dd296e9 100755 (executable)
@@ -1,27 +1,36 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+# DH_VERBOSE = 1
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       cd src && ./configure --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/uanytun/examples && cd ..
+       cd src && ./configure --no-manpage --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/uanytun/examples && cd ..
        touch configure-stamp
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: configure-stamp
        dh_testdir
 
        cd src && $(MAKE) && cd ..
-       cd doc && $(MAKE) && cd ..
 
        touch $@
 
@@ -30,12 +39,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       cd src && $(MAKE) distclean && cd ..
-       cd doc && $(MAKE) clean && cd ..
-
-       # drop leftover file:
-       rm -f src/tun.c
-
        # Add here commands to clean up after the build process.
        $(MAKE) --directory=$(CURDIR)/src distclean
        dh_clean
@@ -67,7 +70,7 @@ binary-arch: install
        dh_link
        dh_strip
        dh_compress
-       mkdir -p debian/uanytun/usr/share/lintian/overrides/ 
+       mkdir -p debian/uanytun/usr/share/lintian/overrides/
        cp -av debian/overrides debian/uanytun/usr/share/lintian/overrides/uanytun
        dh_fixperms
        find debian/uanytun -type f -name config     -exec chmod 600 {} \;