Add debian/source/format file, 3.0 (quilt)
[debian/uanytun.git] / debian / rules
index 1cfd3ad..08bfb72 100755 (executable)
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       cd src && ./configure --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/uanytun/examples && cd ..
+       cd src && ./configure --no-manpage --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/uanytun/examples && cd ..
        touch configure-stamp
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: configure-stamp
        dh_testdir
 
        cd src && $(MAKE) && cd ..
-       cd doc && $(MAKE) && cd ..
 
        touch $@
 
@@ -30,12 +32,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       cd src && $(MAKE) distclean && cd ..
-       cd doc && $(MAKE) clean && cd ..
-
-       # drop leftover file:
-       rm -f src/tun.c
-
        # Add here commands to clean up after the build process.
        $(MAKE) --directory=$(CURDIR)/src distclean
        dh_clean