Drop asciidoc and related packages from build-depends and ship manpages statically...
[debian/uanytun.git] / debian / rules
index 1cfd3ad..b6b42b9 100755 (executable)
@@ -12,7 +12,7 @@
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       cd src && ./configure --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/uanytun/examples && cd ..
+       cd src && ./configure --no-manpage --prefix=/usr --sysconfdir=/etc --examplesdir=/usr/share/uanytun/examples && cd ..
        touch configure-stamp
 
 build: build-stamp
@@ -21,7 +21,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        cd src && $(MAKE) && cd ..
-       cd doc && $(MAKE) && cd ..
 
        touch $@
 
@@ -30,12 +29,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       cd src && $(MAKE) distclean && cd ..
-       cd doc && $(MAKE) clean && cd ..
-
-       # drop leftover file:
-       rm -f src/tun.c
-
        # Add here commands to clean up after the build process.
        $(MAKE) --directory=$(CURDIR)/src distclean
        dh_clean
@@ -63,7 +56,7 @@ binary-arch: install
        dh_installdocs
        dh_installexamples
        dh_installinit
-       dh_installman doc/uanytun.8
+       dh_installman debian/uanytun.8
        dh_link
        dh_strip
        dh_compress