Initial Debian packaging; add src/include.mk
[debian/uanytun.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..512ff1c
--- /dev/null
@@ -0,0 +1,75 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       cd src && ./configure && cd ..
+       touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+       dh_testdir
+
+       cd src && $(MAKE) && cd ..
+       cd doc && $(MAKE) && cd ..
+
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       # workarounds:
+       touch src/include.mk
+       rm -f src/tun.c
+
+       cd src && $(MAKE) clean && cd ..
+       cd doc && $(MAKE) clean && cd ..
+
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_installdirs usr/sbin usr/share/uanytun/examples/config
+
+       # Add here commands to install the package into debian/uanytun.
+       install -m 755 src/uanytun debian/uanytun/usr/sbin/
+       cp -a etc/uanytun/*        debian/uanytun/usr/share/uanytun/examples/config/
+
+# Build architecture-independent files here.
+binary-indep: install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs ChangeLog
+       dh_installdocs
+       dh_installexamples
+       dh_installinit etc/init.d/uanytun
+       dh_installman doc/uanytun.8
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure